yes there's now std::mutex
and since we include the whole std namespace that can be problematic at times we should rename that mutex to mtx or similar.
by the way, i think this:
ofScopedLock(mutex)
won't work since the scope of an anonimous variable is just the line in which it's defined so it'll go away immediately unlocking the mutex after that line. you need to create a variable that lasts until the end of that block:
ofScopedLock lock(mtx)
also this is now present in the stl so it's better to use that directly:
std::unique_lock lck(mtx)